Community iRobot: I7+ E Gestione Da Remoto - Community iRobot

Vai al contenuto

  • Non puoi iniziare una nuova discussione
  • Non puoi rispondere a questa discussione

I7+ E Gestione Da Remoto

#1 Utente offline   fpucci 

  • Gruppo: Users
  • Messaggi: 36
  • Iscritto il: 11-March 19

Inviato 05 April 2019 - 08:23 AM

Salve,
Dopo aver eseguito "addestramento" (mapping) e prima pulizia, il Roomba è ritornato alla Clean Base.
Tutti i comandi sono stati eseguiti tramite l'app su smartphone. Tutto perrfettamente funzionante.

Il dispositivo si trova installato presso una seconda casa, dove vado nel fine settimana.
Durante la settimana ho provato a connettermi via remoto al dispositivo tramite app, ma, dove è presente il grosso bottone rotondo del CLEAN), posso avere due tipi di messaggi:
1) Roomba è pronto all'azione (non ricordo la dicitura esatta) (tasto CLEAN abilitato)
2) Il Cloud non riesce a parlare col ROOMBA. Riprovare più tardi (tasto CLEAN disabilitato)


Nel caso1) premo CLEAN e scelgo le stanze da pulire, poi clicco su AVANTI e.... ritorno alla Home Page ma stavolta appare il messaggio descritto in 2)

Insomma, da remoto non c'è verso di stabilire una connessione.
Da cosa dipende ciò?

Faccio presente che la mia casa è abbastanza "domotizzata", nel senso che da remoto controllo con efficacia l'Antifurto, le telecamere di sorveglianza e il riscaldamento, tutti collegati alla stessa WiFi del Roomba e perfettamente comunicanti con le mie APP da remoto.
Ma il Roomba non ne vuole sapere di connettersi?

Che devo fare?

Messaggio modificato da fpucci il 05 April 2019 - 08:25 AM


#2 Utente offline   partenio76 

  • Utente Assiduo
  • StellettaStellettaStellettaStelletta
  • Gruppo: Users
  • Messaggi: 5926
  • Iscritto il: 27-December 15

Inviato 05 April 2019 - 08:45 AM

Visualizza messaggiofpucci, su 05 April 2019 - 08:23 AM, dicono:

Salve,
Dopo aver eseguito "addestramento" (mapping) e prima pulizia, il Roomba è ritornato alla Clean Base.
Tutti i comandi sono stati eseguiti tramite l'app su smartphone. Tutto perrfettamente funzionante.

Il dispositivo si trova installato presso una seconda casa, dove vado nel fine settimana.
Durante la settimana ho provato a connettermi via remoto al dispositivo tramite app, ma, dove è presente il grosso bottone rotondo del CLEAN), posso avere due tipi di messaggi:
1) Roomba è pronto all'azione (non ricordo la dicitura esatta) (tasto CLEAN abilitato)
2) Il Cloud non riesce a parlare col ROOMBA. Riprovare più tardi (tasto CLEAN disabilitato)


Nel caso1) premo CLEAN e scelgo le stanze da pulire, poi clicco su AVANTI e.... ritorno alla Home Page ma stavolta appare il messaggio descritto in 2)

Insomma, da remoto non c'è verso di stabilire una connessione.
Da cosa dipende ciò?

Faccio presente che la mia casa è abbastanza "domotizzata", nel senso che da remoto controllo con efficacia l'Antifurto, le telecamere di sorveglianza e il riscaldamento, tutti collegati alla stessa WiFi del Roomba e perfettamente comunicanti con le mie APP da remoto.
Ma il Roomba non ne vuole sapere di connettersi?

Che devo fare?


Devi verificare che il segnale wi-fi sia presente in maniera sufficiente ove si trova il roomba con la sua home-base: se non lo fosse ti invito a posizionare quest'ultimo, in un posto diverso.

#3 Utente offline   fpucci 

  • Gruppo: Users
  • Messaggi: 36
  • Iscritto il: 11-March 19

Inviato 05 April 2019 - 09:19 AM

Visualizza messaggiopartenio76, su 05 April 2019 - 08:45 AM, dicono:

Devi verificare che il segnale wi-fi sia presente in maniera sufficiente ove si trova il roomba con la sua home-base: se non lo fosse ti invito a posizionare quest'ultimo, in un posto diverso.


Purtroppo devo confermare che, il Roomba si trova più vicino al router WiFi di tutti gli altri dispositivi domotici da me menzionati, e quindi dovrebbe avere il segnale migliore.
Anzi, si trova addirittura alla metà del percorso di dove è posizionato il ricevitore WiFi per l'antifurto ed è alla stessa distanza di dove si trova quello del riscaldamento. Le telecamere sono addirittura esterne alla casa...
Mi sentirei di escludere che sia questione di potenza di segnale, anche perché è posizionato nel salone, dove normalmente mi colloco col portatile connesso al WiFi.
Piuttosto penso ad un problema di connessione con la Cloud di iRobot...

Messaggio modificato da fpucci il 05 April 2019 - 09:21 AM


#4 Utente offline   partenio76 

  • Utente Assiduo
  • StellettaStellettaStellettaStelletta
  • Gruppo: Users
  • Messaggi: 5926
  • Iscritto il: 27-December 15

Inviato 05 April 2019 - 09:23 AM

Visualizza messaggiofpucci, su 05 April 2019 - 09:19 AM, dicono:

Purtroppo devo confermare che, il Roomba si trova più vicino al router WiFi di tutti gli altri dispositivi domotici da me menzionati, e quindi dovrebbe avere il segnale migliore.
Anzi, si trova addirittura alla metà del percorso di dove è posizionato il ricevitore WiFi per l'antifurto ed è alla stessa distanza di dove si trova quello del riscaldamento. Le telecamere sono addirittura esterne alla casa...
Mi sentirei di escludere che sia questione di potenza di segnale, anche perché è posizionato nel salone, dove normalmente mi colloco col portatile connesso al WiFi.
Piuttosto penso ad un problema di connessione con la Cloud ri iRobot...

L'unica soluzione è quella di ripristinare il robot tenendo premuti i tasti dock+spot+clean per 20 secondi.
Oppure dovresti fare la prova quando sei a casa e collegarti non alla rete wi-fi ma da connessione dati del tuo gestore telefonico

#5 Utente offline   fpucci 

  • Gruppo: Users
  • Messaggi: 36
  • Iscritto il: 11-March 19

Inviato 05 April 2019 - 09:32 AM

Visualizza messaggiopartenio76, su 05 April 2019 - 09:23 AM, dicono:

L'unica soluzione è quella di ripristinare il robot tenendo premuti i tasti dock+spot+clean per 20 secondi.
Oppure dovresti fare la prova quando sei a casa e collegarti non alla rete wi-fi ma da connessione dati del tuo gestore telefonico


La cosa che mi incuriosisce è che a volte, generalmente appena apro l'APP, mi dice che il Roomba è pronto per la pulizia ed il tasto CLEAN è abilitato.
Come vado avanti (scelta stanze e avvio) alora si blocca.

Comunque domani domani farò le prove che mi hai chiesto e riporterò il risultato.
Grazie per ora.

#6 Utente offline   partenio76 

  • Utente Assiduo
  • StellettaStellettaStellettaStelletta
  • Gruppo: Users
  • Messaggi: 5926
  • Iscritto il: 27-December 15

Inviato 05 April 2019 - 12:58 PM

Visualizza messaggiofpucci, su 05 April 2019 - 09:32 AM, dicono:

La cosa che mi incuriosisce è che a volte, generalmente appena apro l'APP, mi dice che il Roomba è pronto per la pulizia ed il tasto CLEAN è abilitato.
Come vado avanti (scelta stanze e avvio) alora si blocca.

Comunque domani domani farò le prove che mi hai chiesto e riporterò il risultato.
Grazie per ora.

Premesso che con il ripristino delle impostazioni di fabbrica, azzererai la mappatura memorizzata

#7 Utente offline   fpucci 

  • Gruppo: Users
  • Messaggi: 36
  • Iscritto il: 11-March 19

Inviato 05 April 2019 - 03:22 PM

Visualizza messaggiopartenio76, su 05 April 2019 - 12:58 PM, dicono:

Premesso che con il ripristino delle impostazioni di fabbrica, azzererai la mappatura memorizzata

Non c'è alcun modo di fare un backup per un successivo ripristino?

Se ho 10 mappature (quante ne può contenere l'i7+) di altrettanti appartamenti (quindi ciascuno con più stanze), per rifarle tutte mi ci vorranno settimane....
:unsure:

Messaggio modificato da fpucci il 05 April 2019 - 03:22 PM


#8 Utente offline   partenio76 

  • Utente Assiduo
  • StellettaStellettaStellettaStelletta
  • Gruppo: Users
  • Messaggi: 5926
  • Iscritto il: 27-December 15

Inviato 05 April 2019 - 03:56 PM

Visualizza messaggiofpucci, su 05 April 2019 - 03:22 PM, dicono:

Non c'è alcun modo di fare un backup per un successivo ripristino?

Se ho 10 mappature (quante ne può contenere l'i7+) di altrettanti appartamenti (quindi ciascuno con più stanze), per rifarle tutte mi ci vorranno settimane....
:unsure:

Il roomba i7 può memorizzare sino a 10 mappe.
Domanda:l'icona in alto a destra, quando hai il problema, di che colore è?

#9 Utente offline   fpucci 

  • Gruppo: Users
  • Messaggi: 36
  • Iscritto il: 11-March 19

Inviato 06 April 2019 - 01:15 PM

Ho scoperto quanto segue.
Dopo una settimana che non riuscivo a collegarmi da remoto al Roomba, stamane ho ragiunto la mia casetta.
La WiFi funziona perfettamente.
Ho aperto l'app sul cell ma non riusciva a connettersi al Roomba in nessun modo, né via WiFi né via connessione dati.
Quindi ho toccato il tasto CLEAN sul Roomba... e miracolosamente, automaticamente, mi ha dato la connessione sull'APP. All'istante!

Quindi, deduco che quando il Roomba è in standby non c'è alcun verso di svegliarlo da remoto.
Esiste qualche settaggio che posso fare per impedire che il Roomba vada in perenne letarlo?

Visualizza messaggiopartenio76, su 05 April 2019 - 03:56 PM, dicono:

Il roomba i7 può memorizzare sino a 10 mappe.

Si lo so, è per questo che dico che sarebbe utile che nei prossimi aggiornamenti dell'APP venga inserita la possibilità di un backup/restore delle mappe, perché se disgraziatamente devo fare un reset, per rifarle tutte mi occorreranno molti giorni. Prevenire è meglio che curare...

Visualizza messaggiopartenio76, su 05 April 2019 - 03:56 PM, dicono:

Domanda:l'icona in alto a destra, quando hai il problema, di che colore è?


Adesso sta funzionando correttamente e non c'è alcuna icona.
Appena risuccede il problema aggiorno il post


Grazie e buon gine settimana.

#10 Utente offline   partenio76 

  • Utente Assiduo
  • StellettaStellettaStellettaStelletta
  • Gruppo: Users
  • Messaggi: 5926
  • Iscritto il: 27-December 15

Inviato 06 April 2019 - 03:21 PM

Visualizza messaggiofpucci, su 06 April 2019 - 01:15 PM, dicono:

Ho scoperto quanto segue.
Dopo una settimana che non riuscivo a collegarmi da remoto al Roomba, stamane ho ragiunto la mia casetta.
La WiFi funziona perfettamente.
Ho aperto l'app sul cell ma non riusciva a connettersi al Roomba in nessun modo, né via WiFi né via connessione dati.
Quindi ho toccato il tasto CLEAN sul Roomba... e miracolosamente, automaticamente, mi ha dato la connessione sull'APP. All'istante!

Quindi, deduco che quando il Roomba è in standby non c'è alcun verso di svegliarlo da remoto.
Esiste qualche settaggio che posso fare per impedire che il Roomba vada in perenne letarlo?


Si lo so, è per questo che dico che sarebbe utile che nei prossimi aggiornamenti dell'APP venga inserita la possibilità di un backup/restore delle mappe, perché se disgraziatamente devo fare un reset, per rifarle tutte mi occorreranno molti giorni. Prevenire è meglio che curare...


Adesso sta funzionando correttamente e non c'è alcuna icona.
Appena risuccede il problema aggiorno il post


Grazie e buon gine settimana.

👍

#11 Utente offline   fpucci 

  • Gruppo: Users
  • Messaggi: 36
  • Iscritto il: 11-March 19

Inviato 06 April 2019 - 06:19 PM

Niente da fare, da Remoto il Roomba non si riattiva nemmeno a cannonate, se non lo si sveglia manualmente con un tocco sul CLEAN. Ma da 50 km di distanza non sono abbastanza vicino da toccarlo.

Questo è quello che appare sul mio cell. (immagine allegata al post)

Allega file  IMG_0006.jpg (191.05K)
Numero di downloads: 839

#12 Utente offline   partenio76 

  • Utente Assiduo
  • StellettaStellettaStellettaStelletta
  • Gruppo: Users
  • Messaggi: 5926
  • Iscritto il: 27-December 15

Inviato 06 April 2019 - 10:05 PM

Visualizza messaggiofpucci, su 06 April 2019 - 06:19 PM, dicono:

Niente da fare, da Remoto il Roomba non si riattiva nemmeno a cannonate, se non lo si sveglia manualmente con un tocco sul CLEAN. Ma da 50 km di distanza non sono abbastanza vicino da toccarlo.

Questo è quello che appare sul mio cell. (immagine allegata al post)

Allegato IMG_0006.jpg

Dallo screenshot sembra che il robot non riesce a comunicare correttamente con il robot, può dipendere da diversi fattori....andiamoci per ordine di prove che ti invito a fare:
1) prova a riavviare il router, scollegandolo dalla rete per 15 secondi. Dopo aver ricollegato la corrente, attendi l'inizializzazione del router: Potrebbero volerci massimo 60 secondi. La durata varia in base alla marca e al modello del router;

2) Controllo router: verifica che queste porte firewall sono aperte: 8080, 443 e 8883;

3) Verifica che sia l'APP iRobot Home che la versione software del tuo robot siano aggiornati; versione APP 3.4.1, versione software Roomba 1.6.6

4) Riavvio del router: se i passaggi precedenti non ripristinano la connettività, può essere necessario riavviare il robot: tieni premuto per 20 secondi il tasto CLEAN, o sino a quando tutti i led non si accendono, per poi rilasciarlo


5) Infine, se il riavvio non ripristina la connettività, a malincuore devo consigliarti di effettuare un ripristino di fabbrica sul robot, con il problema che resetti anche le mappe salvate.

Tienimi aggiornato

#13 Utente offline   fpucci 

  • Gruppo: Users
  • Messaggi: 36
  • Iscritto il: 11-March 19

Inviato 07 April 2019 - 01:56 PM

Innanzitutto grazie sempre per la sollecitudine alle richieste di aiuto.



Visualizza messaggiopartenio76, su 06 April 2019 - 10:05 PM, dicono:

Dallo screenshot sembra che il robot non riesce a comunicare correttamente con il robot, può dipendere da diversi fattori....andiamoci per ordine di prove che ti invito a fare:
1) prova a riavviare il router, scollegandolo dalla rete per 15 secondi. Dopo aver ricollegato la corrente, attendi l'inizializzazione del router: Potrebbero volerci massimo 60 secondi. La durata varia in base alla marca e al modello del router;

Lo farò, tanto non mi costa nulla. Ma gli altri dispositivi di domotica stanno funzionando perfettamente da remoto, quindi non penso sia questo il problema.


Visualizza messaggiopartenio76, su 06 April 2019 - 10:05 PM, dicono:

2) Controllo router: verifica che queste porte firewall sono aperte: 8080, 443 e 8883;

Probabilmente queste sono chiuse. Me ne accerterò e eventualmente le aprirò.

Visualizza messaggiopartenio76, su 06 April 2019 - 10:05 PM, dicono:

3) Verifica che sia l'APP iRobot Home che la versione software del tuo robot siano aggiornati; versione APP 3.4.1, versione software Roomba 1.6.6

Verificato ora: tutto perfettamente aggiornato.

Visualizza messaggiopartenio76, su 06 April 2019 - 10:05 PM, dicono:

4) Riavvio del router: se i passaggi precedenti non ripristinano la connettività, può essere necessario riavviare il robot: tieni premuto per 20 secondi il tasto CLEAN, o sino a quando tutti i led non si accendono, per poi rilasciarlo


5) Infine, se il riavvio non ripristina la connettività, a malincuore devo consigliarti di effettuare un ripristino di fabbrica sul robot, con il problema che resetti anche le mappe salvate.

Tienimi aggiornato


Dovrò attendere il prossimo weekend, purtroppo, e questo significa anche che non posso utilizzare il roomba.
Inoltre solleciterei al più presto l'aggiornamento dell'App con una funzionalità di backup/restore, perché è inammissibile perdere tutte le configurazioni considerando il tempo speso per effettuarle. Direi che l'App è gravemente menomata nelle sue funzionalità.

In attesa di aggiornarci al prossimo weekend, vorrei solamente soffermarmi un attimo su una cosa.
Sull'App, in Impostazioni->Modalità StandBy a potenza ridotta appare una pagina (ma perché in inglese? non paghiamo abbastanza per avere documentazione in italiano?) dove c'è scritto che il roomba si mette in una situazione di standy By dal WoiFi per risparmiare energia. Per attivare questa funzionalità bisogna premere il pulsante di Spot.
Ok, ma io questo pulsante non l'ho mai premuto.
E come si DISABILITA questa funzionalità? Non c'è scritto se non toccando il tasto CLEAN.
Ma se io sono molto distante dal dispositivo, questo vuol dire che una volta che Roomba è entrato in modalità StandBy, io non posso più svegliarlo. Punto.
Ritengo che sia un vero e proprio bug di sistema.
Oltretutto si attiva automaticamente e non c'è verso di disattivarlo.

Messaggio modificato da fpucci il 07 April 2019 - 01:57 PM


#14 Utente offline   partenio76 

  • Utente Assiduo
  • StellettaStellettaStellettaStelletta
  • Gruppo: Users
  • Messaggi: 5926
  • Iscritto il: 27-December 15

Inviato 07 April 2019 - 06:29 PM

Visualizza messaggiofpucci, su 07 April 2019 - 01:56 PM, dicono:

Innanzitutto grazie sempre per la sollecitudine alle richieste di aiuto.




Lo farò, tanto non mi costa nulla. Ma gli altri dispositivi di domotica stanno funzionando perfettamente da remoto, quindi non penso sia questo il problema.



Probabilmente queste sono chiuse. Me ne accerterò e eventualmente le aprirò.


Verificato ora: tutto perfettamente aggiornato.



Dovrò attendere il prossimo weekend, purtroppo, e questo significa anche che non posso utilizzare il roomba.
Inoltre solleciterei al più presto l'aggiornamento dell'App con una funzionalità di backup/restore, perché è inammissibile perdere tutte le configurazioni considerando il tempo speso per effettuarle. Direi che l'App è gravemente menomata nelle sue funzionalità.

In attesa di aggiornarci al prossimo weekend, vorrei solamente soffermarmi un attimo su una cosa.
Sull'App, in Impostazioni->Modalità StandBy a potenza ridotta appare una pagina (ma perché in inglese? non paghiamo abbastanza per avere documentazione in italiano?) dove c'è scritto che il roomba si mette in una situazione di standy By dal WoiFi per risparmiare energia. Per attivare questa funzionalità bisogna premere il pulsante di Spot.
Ok, ma io questo pulsante non l'ho mai premuto.
E come si DISABILITA questa funzionalità? Non c'è scritto se non toccando il tasto CLEAN.
Ma se io sono molto distante dal dispositivo, questo vuol dire che una volta che Roomba è entrato in modalità StandBy, io non posso più svegliarlo. Punto.
Ritengo che sia un vero e proprio bug di sistema.
Oltretutto si attiva automaticamente e non c'è verso di disattivarlo.

Se il Roomba è impostato in modalità "standy a potenza ridotta ", l'APP del roomba non sarà in grado di comunicare con il robot; per uscire dalla modalità Standby alimentazione ridotta, premi una volta CLEAN per attivare Roomba, quindi premere CLEAN ancora una volta per iniziare un lavoro di pulizia. Una volta che Roomba è stato in funzione per un minuto, la modalità Standby alimentazione ridotta verrà disattivata.
La pressione del tasto CLEAN deve essere fatto dal robot e non dall'APP.
Verifica anche questo passaggio

Messaggio modificato da partenio76 il 07 April 2019 - 06:31 PM


#15 Utente offline   fpucci 

  • Gruppo: Users
  • Messaggi: 36
  • Iscritto il: 11-March 19

Inviato 07 April 2019 - 10:23 PM

Visualizza messaggiopartenio76, su 07 April 2019 - 06:29 PM, dicono:

Se il Roomba è impostato in modalità "standy a potenza ridotta ", l'APP del roomba non sarà in grado di comunicare con il robot; per uscire dalla modalità Standby alimentazione ridotta, premi una volta CLEAN per attivare Roomba, quindi premere CLEAN ancora una volta per iniziare un lavoro di pulizia. Una volta che Roomba è stato in funzione per un minuto, la modalità Standby alimentazione ridotta verrà disattivata.
La pressione del tasto CLEAN deve essere fatto dal robot e non dall'APP.
Verifica anche questo passaggio

Ma è proprio questo il punto, e mi scuso se prima non sono stato abbastanza chiaro.

Mi trovavo vicino al Roomba, ho premuto il CLEAN sul Roomba, l'app l'ha visto subito (connessione attivata) e l'ho avviato per la pulizia da APP. Ovviamente mi trovavo nella casa del Roomba.
Ma quando ha terminato il suo giro di pulizia (durato circa un'ora e venti minuti) ed è ritornata alla Clean Base, si è rimessa in stand by da sola e non c'è stato verso di riattivarla. Nel frattempo ero uscito di casa e volevo riattivarlo per fargli ripulire una sola delle stanze. Ma non è stato possibile, ormai era in stanby.
Se ogni volta che la uso essa si rimette in standy by allora il funzionamento da remoto non funzionerà mai.

Bisognerebbe togliere la modalità "stand by a potenza ridotta" in maniera permanente. Come si fa?

Messaggio modificato da fpucci il 07 April 2019 - 10:24 PM


#16 Utente offline   partenio76 

  • Utente Assiduo
  • StellettaStellettaStellettaStelletta
  • Gruppo: Users
  • Messaggi: 5926
  • Iscritto il: 27-December 15

Inviato 08 April 2019 - 07:26 AM

Visualizza messaggiofpucci, su 07 April 2019 - 10:23 PM, dicono:

Ma è proprio questo il punto, e mi scuso se prima non sono stato abbastanza chiaro.

Mi trovavo vicino al Roomba, ho premuto il CLEAN sul Roomba, l'app l'ha visto subito (connessione attivata) e l'ho avviato per la pulizia da APP. Ovviamente mi trovavo nella casa del Roomba.
Ma quando ha terminato il suo giro di pulizia (durato circa un'ora e venti minuti) ed è ritornata alla Clean Base, si è rimessa in stand by da sola e non c'è stato verso di riattivarla. Nel frattempo ero uscito di casa e volevo riattivarlo per fargli ripulire una sola delle stanze. Ma non è stato possibile, ormai era in stanby.
Se ogni volta che la uso essa si rimette in standy by allora il funzionamento da remoto non funzionerà mai.

Bisognerebbe togliere la modalità "stand by a potenza ridotta" in maniera permanente. Come si fa?

Come spiegato nel mio precedente post, per disabilitare lo stand by a potenza ridotta devi premere il tasto fisico CLEAN direttamente dal robot quando questo si trova sulla sua base di ricarica e non dall'APP e farlo funzionare per più di un minuto

Messaggio modificato da partenio76 il 08 April 2019 - 07:27 AM


#17 Utente offline   fpucci 

  • Gruppo: Users
  • Messaggi: 36
  • Iscritto il: 11-March 19

Inviato 06 May 2019 - 11:25 AM

Ho applicato pedissequamente le tue indicazioni per disabilitare lo standby.
Ho modificato il firewall per aprire le tre porte indicate sull'help dell'appl di iRobot.
Sono uscito di casa e ho disabilitato la connessione WiFi.
Sono riuscito a far partire la connessione da remoto, quindi utilizzando la rete dati del telefono.
Il Roomba ha fatto il suo giro completo di pulizia.

Stamattina, sempre da remoto, ho provato a riavviarlo, ma mi dice che la cloud non riesce a comunicare col roomba.

Non c'è verso di farlo funzionare da remoto!
Me ne dispaice molto perché ho scelto l'7+ per due motivi: 1) attivazione da remoto 2) svuotamento automatico serbatoio.
Ma senza il punto 1) tutto è vanificato e temo di aver speso i miei soldi inutilmente.
Grazie lo stesso.

#18 Utente offline   partenio76 

  • Utente Assiduo
  • StellettaStellettaStellettaStelletta
  • Gruppo: Users
  • Messaggi: 5926
  • Iscritto il: 27-December 15

Inviato 06 May 2019 - 12:27 PM

Visualizza messaggiofpucci, su 06 May 2019 - 11:25 AM, dicono:

Ho applicato pedissequamente le tue indicazioni per disabilitare lo standby.
Ho modificato il firewall per aprire le tre porte indicate sull'help dell'appl di iRobot.
Sono uscito di casa e ho disabilitato la connessione WiFi.
Sono riuscito a far partire la connessione da remoto, quindi utilizzando la rete dati del telefono.
Il Roomba ha fatto il suo giro completo di pulizia.

Stamattina, sempre da remoto, ho provato a riavviarlo, ma mi dice che la cloud non riesce a comunicare col roomba.

Non c'è verso di farlo funzionare da remoto!
Me ne dispaice molto perché ho scelto l'7+ per due motivi: 1) attivazione da remoto 2) svuotamento automatico serbatoio.
Ma senza il punto 1) tutto è vanificato e temo di aver speso i miei soldi inutilmente.
Grazie lo stesso.

Mi dice qual'è il gestore della compagnia telefonica adsl e la marca del modem?

#19 Utente offline   fpucci 

  • Gruppo: Users
  • Messaggi: 36
  • Iscritto il: 11-March 19

Inviato 06 May 2019 - 03:38 PM

Visualizza messaggiopartenio76, su 06 May 2019 - 12:27 PM, dicono:

Mi dice qual'è il gestore della compagnia telefonica adsl e la marca del modem?

Il gestore è Infostrada, per telefonia fissa e ADSL.

Il modem/router è un USRobotis SureConnect 9600 (Non è WiFi) connesso direttamente all'ADSL.
Mentre SOLO PER IL WiFi, collegato in cascata al Router precedente, uso un Netgear (causa di un guasto al circuito modem, funziona solo come WiFi), mi pare un D600.
Le porte del firewall sono aperte su entrambi i router.
Inoltre ho anche un TP-LINK TL-WPA8630 KIT Gigabit Powerline AV1200 che uso come extender per la WiFi.

Premetto che a tali router, nella stessa maniera del Roomba, sono connessi e perfettamente funzionanti da remoto, anche:
  • Antifurto
  • Termostato caldaia
  • Telecamere di videosorveglianza

e tali dispositivi sono perfettamente comandabili da remoto nelle loro piene funzionalità.

Grazie.

#20 Utente offline   partenio76 

  • Utente Assiduo
  • StellettaStellettaStellettaStelletta
  • Gruppo: Users
  • Messaggi: 5926
  • Iscritto il: 27-December 15

Inviato 06 May 2019 - 03:41 PM

Visualizza messaggiofpucci, su 06 May 2019 - 03:38 PM, dicono:

Il gestore è Infostrada, per telefonia fissa e ADSL.

Il modem/router è un USRobotis SureConnect 9600 (Non è WiFi) connesso direttamente all'ADSL.
Mentre SOLO PER IL WiFi, collegato in cascata al Router precedente, uso un Netgear (causa di un guasto al circuito modem, funziona solo come WiFi), mi pare un D600.
Le porte del firewall sono aperte su entrambi i router.
Inoltre ho anche un TP-LINK TL-WPA8630 KIT Gigabit Powerline AV1200 che uso come extender per la WiFi.

Premetto che a tali router, nella stessa maniera del Roomba, sono connessi e perfettamente funzionanti da remoto, anche:
  • Antifurto
  • Termostato caldaia
  • Telecamere di videosorveglianza

e tali dispositivi sono perfettamente comandabili da remoto nelle loro piene funzionalità.

Grazie.

Ma dove è posizionato roomba è connesso con il ripetitore o il wifi netgare?

#21 Utente offline   fpucci 

  • Gruppo: Users
  • Messaggi: 36
  • Iscritto il: 11-March 19

Inviato 07 May 2019 - 07:56 AM

Visualizza messaggiopartenio76, su 06 May 2019 - 03:41 PM, dicono:

Ma dove è posizionato roomba è connesso con il ripetitore o il wifi netgare?


Il ripetitore l'ho riportato solo per completezza, ma non ha alcun ruolo col Roomba.
Il Roomba è connesso SOLO col NetGear, che comunque riesce a coprire "abbastanza" tutta casa. Il repeater serve solo per portarmi il segnale fuori in giardino e rafforzate il segnale nei punti più lontani rispetto al NetGear. In ogni caso il Roomba non ne conosce l'esistenza.
La base del roomba è messa proprio al centro di casa, proprio perché il robot, spostandosi, possa rimanere nel raggio di "ascolto" della base.

In allegato la mappa, dove è possibile vedere anche la collocazione della base del Roomba.
Il WiFi e il router sono ubicati in camera da letto (è l'unico ingresso dell'ADSL).
Il repeater (comunque non coinvolto) si trova in cucina.

Allega File(s)



#22 Utente offline   partenio76 

  • Utente Assiduo
  • StellettaStellettaStellettaStelletta
  • Gruppo: Users
  • Messaggi: 5926
  • Iscritto il: 27-December 15

Inviato 07 May 2019 - 08:45 AM

Visualizza messaggiofpucci, su 07 May 2019 - 07:56 AM, dicono:

Il ripetitore l'ho riportato solo per completezza, ma non ha alcun ruolo col Roomba.
Il Roomba è connesso SOLO col NetGear, che comunque riesce a coprire "abbastanza" tutta casa. Il repeater serve solo per portarmi il segnale fuori in giardino e rafforzate il segnale nei punti più lontani rispetto al NetGear. In ogni caso il Roomba non ne conosce l'esistenza.
La base del roomba è messa proprio al centro di casa, proprio perché il robot, spostandosi, possa rimanere nel raggio di "ascolto" della base.

In allegato la mappa, dove è possibile vedere anche la collocazione della base del Roomba.
Il WiFi e il router sono ubicati in camera da letto (è l'unico ingresso dell'ADSL).
Il repeater (comunque non coinvolto) si trova in cucina.

A questo punto mi va di pensare che sia un problema del gestore telefonico.
La prova del "9" la potresti fare utilizzando come router un normalissimo smartphone dandone la condivisione ( router wi-fi) per poi configurare attraverso un secondo smartphone la nuova connessione---》roomba, e provare se il sistema funziona.
Se è così, a questo punto hai le porte bloccate da parte del gestore telefonico, quindi devi chiamare loro per vedere se è possibile risolvere il problema.
Tienimi aggiornato

#23 Utente offline   loaderit 

  • Gruppo: Users
  • Messaggi: 1
  • Iscritto il: 09-May 19

Inviato 09 May 2019 - 02:32 PM

Dopo aver perso un po' di tempo su un problema simile ho scoperto una cosa che a me ha risolto il problema di connettività.
Il problema era il servizio DNS. Configurando un DNS interno alla rete locale, il Roomba non riesce a collegarsi al cloud.
Cambiando la configurazione IP e impostandola manualmente invece che con DHCP, ho impostato come DNS primario 1.1.1.1 e come DNS secondario 1.0.0.1.
Così funziona tutto.
Evidentemente il servizio DNS interno che inoltra le richieste all'esterno non risolve correttamente qualche richiesta, forse per via di qualche protocollo relativamente recente. Immagino che possa essere un problema comune a chi ha una rete locale con un DNS sul model, sul router, o su un server interno.

Quindi non era un problema di firewall, ma solo di risoluzione di nomi.

Magari il prossimo si salva un po' di ore di prove...

#24 Utente offline   fpucci 

  • Gruppo: Users
  • Messaggi: 36
  • Iscritto il: 11-March 19

Inviato 09 May 2019 - 03:48 PM

Visualizza messaggioloaderit, su 09 May 2019 - 02:32 PM, dicono:

Dopo aver perso un po' di tempo su un problema simile ho scoperto una cosa che a me ha risolto il problema di connettività.
Il problema era il servizio DNS. Configurando un DNS interno alla rete locale, il Roomba non riesce a collegarsi al cloud.
Cambiando la configurazione IP e impostandola manualmente invece che con DHCP, ho impostato come DNS primario 1.1.1.1 e come DNS secondario 1.0.0.1.
Così funziona tutto.
Evidentemente il servizio DNS interno che inoltra le richieste all'esterno non risolve correttamente qualche richiesta, forse per via di qualche protocollo relativamente recente. Immagino che possa essere un problema comune a chi ha una rete locale con un DNS sul model, sul router, o su un server interno.

Quindi non era un problema di firewall, ma solo di risoluzione di nomi.

Magari il prossimo si salva un po' di ore di prove...


Grazie, gran bella dritta!
La proverò sicuramente anche se.... sono già molto vicino all'aver applicato il consiglio.
Infatti, per mia scelta, tutte le mie reti sono con IP Statico (ed il Roomba non fa eccezione) e il DNS utilizzo quello di Google (ossia: Primario: 8.8.8.8 e Secondario: 8.8.4.4).
Conosco il DNS 1.1.1.1 ma non l'ho provato e, sinceramente, non vedo molta differenza (concettualmente) da quello di Google.
Ma a questo punto, tentar non nuoce. Pubblicherò l'esito appena potrò fare anche questo test.
Per il momento, grazie per il supporto! :-)

#25 Utente offline   partenio76 

  • Utente Assiduo
  • StellettaStellettaStellettaStelletta
  • Gruppo: Users
  • Messaggi: 5926
  • Iscritto il: 27-December 15

Inviato 09 May 2019 - 08:47 PM

Visualizza messaggiofpucci, su 09 May 2019 - 03:48 PM, dicono:

Grazie, gran bella dritta!
La proverò sicuramente anche se.... sono già molto vicino all'aver applicato il consiglio.
Infatti, per mia scelta, tutte le mie reti sono con IP Statico (ed il Roomba non fa eccezione) e il DNS utilizzo quello di Google (ossia: Primario: 8.8.8.8 e Secondario: 8.8.4.4).
Conosco il DNS 1.1.1.1 ma non l'ho provato e, sinceramente, non vedo molta differenza (concettualmente) da quello di Google.
Ma a questo punto, tentar non nuoce. Pubblicherò l'esito appena potrò fare anche questo test.
Per il momento, grazie per il supporto! :-)

Tienici aggiornato, così da essere utile per tutti

Condividi questa discussione:


  • Non puoi iniziare una nuova discussione
  • Non puoi rispondere a questa discussione

1 utente(i) stanno leggendo questa discussione
0 utenti, 1 ospiti, 0 utenti anonimi